P0: We are experiencing outage

Incident Report for NRP

Postmortem

Symptom:
Failure to create agreements when generating calculations

Impact:
Advisors were unable to create agreements

Root Cause:
The calculation service was impacted by a change in the number of decimals used for bond prices.
This bug was identified and fixed the day before in a single product, but it proved that it affected several other products after an update to their respective bond prices.
This alteration to the amount of decimals, led to a persistence issue, as the database schema was not designed to accommodate the updated format.

Resolution:
A fix was implemented to enable the service to handle the new decimal format on all products.
The updated service was successfully deployed and initially verified from a technical perspective. The solution was verified the following morning from

Actions:
A retrospective and problem management session will be conducted to review this and the associated incident from the day before. Several internal factors complicated the process for deploying the fix, resulting in unnecessary delays. These contributing factors will be examined to improve the efficiency of future bug resolution and deployment processes.

Reference: IM522806

Event started at: 09:47
Event ended at: 17:30

Posted Oct 24, 2025 - 09:06 CEST

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 17:52 CEST

Monitoring

A fix has been implemented.
We are monitoring the the situation and await final confirmation that the issue is no longer present.

Next status: tomorrow at 09:00
Posted Oct 21, 2025 - 17:45 CEST

Identified

The bug has been identified and a release is being prepared.
We expect the release will be deployed to production later tonight

Next status: 19:00 (Or if the release get to production faster that expected)
Posted Oct 21, 2025 - 14:32 CEST

Investigating

Symptom:
Failing when creating agreements.

Reference: IM522806

Technical impact:
Not able to update some portfolio-calculations

Business impact:
Not able to create some agreements with calculations

Next status: 14:30
Posted Oct 21, 2025 - 13:04 CEST
This incident affected: NRP Production (Mortgage Calculation, Mortgage Agreement).