P0: We are experiencing outage

Incident Report for NRP

Postmortem

Symptom

Incident report and alerts on failed attempts to generate new real property matches.

Impact

It was not possible generate new real property matches.
This affected creation of calculations and agreements with properties which did not have updated information from the Land Registry

Root cause

After the nightly restart the the real property matcher service was not able to call the land register connector service.

Resolution

The servers containing the connector service was restarted based on work around for this known error.

Actions

Alerts are in place, but symptoms only occur when a client asks for a real property match.
The error is known, but the root cause of why the service looses connection to each other is unknown. The frequency of this know error is approx. once a year

Reference: IM514460

Event started at: 05:00
Event ended at: 11:27
Recorded Downtime: 6 hours and 27 minutes

Posted Sep 29, 2025 - 15:33 CEST

Resolved

The queue is now finished and the service is back to normal operation
Posted Sep 29, 2025 - 12:13 CEST

Monitoring

A restart of the service has fix the issue.

The queue of matches will be processed and should be finished in 15 minutes
Posted Sep 29, 2025 - 11:27 CEST

Investigating

Symptom: Reports of failing matches of real property

reference: IM514460

Technical impact:
Not Possible to generate new real property matches,

Business impact:
Not possible to create calculations and agreements with properties which does not have updated real property match

Next status: 12:30
Posted Sep 29, 2025 - 10:48 CEST
This incident affected: NRP Production (Mortgage Calculation, Mortgage Agreement, Real Property).