P0: We are experiencing outage

Incident Report for NRP

Postmortem

Symptom:
Failure to create agreements when generating calculations based on fixed-price bonds.

Impact:
Advisors were unable to create agreements tied to the newest fixed-price bond.

Root Cause:
The calculation service was impacted by a change in the number of decimals used for bond prices. This alteration led to a persistence issue, as the database schema was not designed to accommodate the updated format.

Resolution:
A fix was implemented to enable the service to handle the new decimal format. The updated service was successfully deployed.

Actions:
A retrospective and problem management session will be conducted to review the incident. Several internal factors complicated the process for deploying the fix, resulting in unnecessary delays. These contributing factors will be examined to improve the efficiency of future bug resolution and deployment processes.

Reference: IM522806

Event started at: 13:47
Event ended at: 19:29

Posted Oct 24, 2025 - 08:49 CEST

Resolved

The fix has been released and been verified to fix the issue with fixed-price calculations.

All failing calculations can be refreshed through the "Calculation Update Check"
Posted Oct 20, 2025 - 19:34 CEST

Update

We are awaiting for the fix to the bug to reach production.

Next Status: 19:30
Posted Oct 20, 2025 - 17:52 CEST

Update

We are still working on getting the fix to production.

Next status: 17:30
Posted Oct 20, 2025 - 15:49 CEST

Identified

We have found the root cause of this issue and is preparing a bug-fix for deployment as soon as possible.

Next status: when the bug fix has been verified or at 15:30
Posted Oct 20, 2025 - 14:14 CEST

Investigating

Symptom:
Failing agreement flow because Portfolio Calculation is not up to date.

Reference:IM522806

Technical impact:
Portfolio calculation is failing on a data error when fetching bonds

Business impact:
For some agreement cases, with fixed-price calculations, the agreement flow will fail at the create agreement step.

Information regarding this issue has also been posted on Xperten?

Next status: 15:30
Posted Oct 20, 2025 - 14:12 CEST
This incident affected: NRP Production (Mortgage Calculation, Mortgage Agreement).