P0: We are experiencing outage

Incident Report for NRP

Postmortem

Symptom

Alerts on Errors in Mortgage Agreement, Agreement Validator and Credit Indicator

Impact

Systems and users trying to fetch-agreement-conditions and credit-score-applications

Root cause

An systemuser calling the customer setup on mainframe was revoked due to wrong password. These calls to mainframe indirectly cause the the calls to the affectes APIs to fail further along in the process due to missing customer information.
The user was revoked due to a wrong or missing password in a key vault introduced by a deployment.

Resolution

The affected customer service was rolled back to not using key vault for password and the user was unlocked

Actions

Investigations into why the password was not supplied by the key vault

Reference: INC0070347/INC0070342

Event started at: 11:00 09/09/2026
Event ended at: 13:56 09/09/2026

Posted Sep 09, 2026 - 14:59 CEST

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 13:54 CEST

Investigating

Symptom: Errors in Mortgage Agreement, Agreement Validator and Credit Score
Reference: INC0070347
Technical impact: Unknown
Business impact: Unknown
Next status: 14:00
Posted Sep 09, 2026 - 12:40 CEST
This incident affected: NRP Production (Agreement Validator, Mortgage Agreement, Credit Score).