P0: We are experiencing outage

Incident Report for NRP

Postmortem

Symptom

Agreement remains in state ACCEPTED and no documents was created and sent to DCs / FIs.

Impact

Agreements with prepayments was stuck in a state before documents generated. 11 agreements with signing same day had a impact if not possible to deliver documents before signing deadline.

Remaining customers could end up receiving their documents later than expected. Eg. FI Advisors may need to sent the documents next day.

Root Cause

On Saturday due to quaterly termin, a significant amount of prepayment events was build up. Due to the design of the service rs-rp-prepayment-activitity-service, it it could not process these events 80.000+ in total, in the same batch. This resulted in contiously rolling back the transaction. Because of this no prepayments events was exposed to “Agreement” leading to documents not generated.

Resolution

Development team issued a hotfix, changing the flow to process 1 event in one database transaction, and not all events in 1 transaction which fixed the problem. This fix considered a permanent fix.

We suspect the issue appeared because of a unusual higher amount of transaction from Saturday.

Actions

Reference:  INC0038166

Event started at:  2026-04-11 01:00 ( Totalkredit was notified around 11:45 o’clock).
Event ended at: 2026-04-13 16:15

Posted Apr 13, 2026 - 20:47 CEST

Resolved

Agreement flow is operational
Posted Apr 13, 2026 - 16:41 CEST

Monitoring

The bug fix has been deployed and prepayment events are being processed. Once the queue has been handled the agreement flow will pick up the agreements waiting for prepayment created.

Next status: tomorrow at 09:00
Posted Apr 13, 2026 - 16:07 CEST

Update

We have identified the issue and are currently working on a fix for the bug

No agreements can be processed before the fix han been deployed. All stuck agreements will be handled afterwards.

Next status 16:45
Posted Apr 13, 2026 - 14:45 CEST

Update

We are still investigation the issue of agreements stuck in creating prepayment.

Next status: 15:00
Posted Apr 13, 2026 - 13:36 CEST

Investigating

Symptom: We are currently not processing agreements

reference: INC0038166

Technical impact: missing prepayment created events

Business impact: not able to generate agreement

Next status: 13:30
Posted Apr 13, 2026 - 11:59 CEST
This incident affected: NRP Production (Mortgage Agreement).